Computers, Wordpress

WP-Hive upgrade prevents WordPress login

I upgraded the wp-hive plug-in to version 0.5 earlier today. It wasn’t an active plugin for me and I needn’t have upgraded it. But I did it earlier today and didn’t think twice about it.

Later, I found out that I could not login into WordPress as an administrator. Everything else seemed to be working fine. Site was up and running as usual, but I couldn’t access my dashboard.

When I checked the WordPress database through phpMyAdmin the wp_options table was perfect. I was soon able to figure out that this was not a WordPress problem.

So I started troubleshooting by trying to undo my last set of actions, one of which was upgrading the wp-hive plugin. Renaming the wp-hive folder gave an serious error and brought the site down. With that I was able to narrow down the problem to the file

/wp-contents/db.php

I remmed out the line

/*require_once( WP_CONTENT_DIR . ‘/plugins/wp-hive/do-prefix.php’);
*/

Everything is back to normal for me now because I dont use wp-hive.

I didn’t find anything about this problem in Google, so I decided to write this down.

Advertisements

2 thoughts on “WP-Hive upgrade prevents WordPress login

  1. You might be better off just deleting /wp-content/db.php from the filesystem, which will also de-activate WP Hive plugin. Someone else reported a bug like this earlier, so I’m going to have to look into it a little more.

    Thanks for pointing it out.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s